FileForums

FileForums (https://fileforums.com/index.php)
-   Conversion Tutorials (https://fileforums.com/forumdisplay.php?f=55)
-   -   Lzma Bug/Problem (https://fileforums.com/showthread.php?t=104460)

Peeping_John 27-05-2021 17:26

Lzma Bug/Problem
 
There's a problem when compressing with Lzma.
When the compression starts, lzma says that my disk is full.
Even though I still have 300+ GB of space.
How can I fix this Bug/Problem?
Thanks. :D

:( Sad8669 27-05-2021 21:55

Please show me your configuration for LZMA in arc.ini, there must be something wrong.

It should look like this :
Code:

[External compressor:rep,mm,exe,exe2,4x4,lzma]
header    = 0
packcmd  = "FAZip" -i0  compress:{compressor}{:option} <stdin> <stdout>


Peeping_John 27-05-2021 23:05

Quote:

Originally Posted by :( Sad8669 (Post 492458)
Please show me your configuration for LZMA in arc.ini, there must be something wrong.

It should look like this :
Code:

[External compressor:rep,mm,exe,exe2,4x4,lzma]
header    = 0
packcmd  = "FAZip" -i0  compress:{compressor}{:option} <stdin> <stdout>


I have this:

Code:

[External compressor:lzma2]
header    = 0
default  = :d25:fb=273:mf=bt4:mc=1000000:lc=4:lp=0
packcmd  = 7z.exe a -txz -an -mcrc=0 -m1=lzma2{:option}:mf=bt4 -mmt=on -mx9 -si -so <stdin> <stdout>


:( Sad8669 28-05-2021 00:50

This is LZMA2, it uses 7zip. it is also known as XZ.

Side Notes : I have some work to do, use either a different compressor for now or wait till someone helps or i return.

Edit : I am back, so you see the default section up there? just remove it.

Like this :

Code:

[External compressor:lzma2]
header    = 0
packcmd  = 7z.exe a -txz -an -mcrc=0 -m1=lzma2{:option}:mf=bt4 -mmt=on -mx9 -si -so <stdin> <stdout>


panker1992 28-05-2021 11:21

[External compressor:lzma2]
header = 0
packcmd = "lz\xz" a -txz -an -m0=lzma2{:option}:fb=273:mf=bt4:mc=100000000:lc=4: lp=0 -mx9 -si -so <stdin> <stdout>
unpackcmd = dec x -txz -an -y -si -so <stdin> <stdout>
there you are

Prince4 08-06-2021 08:40

So i also tried adding LZMA2 to my compressor, but it still gives me the same DiskFull Error. When i ues this :


Code:

7z19 a -t7z -an -m0=lzma2:fb=273:mf=bt4:mc=100000000 -mx9 -mmt=4 -si -so <stdin> <stdout>

But when i use this it gives me "System ERROR: Not Implemented"



Code:

7z19 a -t7z -an -m0=lzma2:fb=273:mf=bt4:mc=100000000 -mx9 -mmt=4 -si<stdin> -so <stdout>

When running the command without "-si,so,(stdin><stdout>" in command line i can compress files just fine.

:( Sad8669 08-06-2021 10:10

Code:

[External compressor:lzma2]
header    = 0
packcmd  = 7z.exe a -txz -an -mcrc=0 -m1=lzma2{:option}:mf=bt4 -mmt=on -mx9 -si -so <stdin> <stdout>


Prince4 08-06-2021 12:00

Quote:

Originally Posted by :( Sad8669 (Post 492793)
...

The problem was -txz, dunno why it didn't work before when i HAD -txz in the first place. :\
Thanks tho.


All times are GMT -7. The time now is 04:01.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright 2000-2020, FileForums @ https://fileforums.com